ARDUINO34.RU Форум ARDUINO34.RU Форум
 Поиск    Участники
Сегодня: 23.07.2018 - 14:54:40
   ARDUINO34.RU Форум -> Мелочь... а не приятно. -> модуль Bluetooth HC-06 - привет из Чины :)
Страницы:  1  
АвторСообщение

bujanoff

участник форума




Статистика:
Тем создано: 129
Сообщений: 522
Репутация: 2066 ±
Сегодня при работе с блютуз модулем Bluetooth HC-06



Столкнулся с интересной и для меня новой проблемой... Точнее с двумя.
Наверное надо сразу оговориться , что с этим модулем работаю впервые, да и вообще синезубого брата не осень уважаю как девайс... но на WiFi средств нет , а необходимость в удаленном управлении есть.

Заливаю проги (в уно и в смартфон), вскрываю упаковку с модулем , подключаю согласно рисунка на плате :

HC06 / UNO
vcc - 3.3v
Gnd - Gnd
Rxd - Tx
Txd - Rx

и ничего... светодиод не мигает, обе микрухи на модуле греются..., короче не работает, и так и сяк - ноль. пробовал и 5 вольт подавать и от внешнего источника. Ну думаю - при транспортировке повредили или изначально нерабочий. Снял, бросил ко всему хламу не рабочему...
Но после обеда выглянуло солнышко... Дай думаю еще разочек, вдруг остыл
Смотрю на обратную сторонуи понять не могу- самая "жирная" дорожка идет к TXD вместо земли. А чем , думаю, черт не шутит , один ... не работает - перебрасываю в зеркальной последовательности и... все работает. Не убило ни 5 вольт на другие ноги (кстати RXD и TXD выдерживают до 7ми вольт....), ни дорога в 8000 км... ШЕЛКОГРАФИЯ на изнанку нанесена!!!

Вот как то так...

Проблема вторая - с компом коммутируется отлично, а вот с андроидом не хочет.
Может кто подскажет почему?

Ниже фото с нормальным подключением :

Прикреплён файл:
--------------------------------------------------
3D-печать 79610782657
Сообщение # 1 01.10.2014 в 15:51:26

Вячеслав



гость
Возможно проблема с мак адресами ?
Сообщение # 2 11.10.2014 в 22:09:27
Страницы:  1  
Администратор запретил отвечать гостям на сообщения! Для регистрации пройдите по ссылке: зарегистрироваться


Powered by WR-Forum Professional © 1.9.9